Forum EPW
http://epwforum.uk/

EPW5.3
http://epwforum.uk/viewtopic.php?f=3&t=668
Page 1 of 1

Author:  inoka [ Fri Jul 13, 2018 3:06 pm ]
Post subject:  EPW5.3

Dear developers

Could you please let me know which version of QE is the best for EPW 5.0?

QE 6.3 , 6.2.2 or else?

Thank you in advance

Inoka

Author:  sponce [ Wed Jul 18, 2018 9:58 am ]
Post subject:  Re: EPW5.3

Hello,

If you download QE 6.3 https://www.quantum-espresso.org/news-e ... esso-v-6-3
it comes with the corresponding EPW 5.

This is the version you should use.

Best wishes,
Samuel

Author:  inoka [ Tue Jul 31, 2018 2:33 pm ]
Post subject:  Re: EPW5.3

Dear Dr. Samuel

Thank you. We installed QE 6.3 in our supercomputer.

I tried the Exercise 1 (lead) in the 2018 workshop. However I got an error in the epw.in calculation.

task # 2
from readwfc : error # 20
error opening wfc file


I tried the same example with the QE 6.2.2 in my computer (downloaded from https://gitlab.com/QEF/q-e as per your instructions given http://epwforum.uk/viewtopic.php?f=3&t=505). I could finish the calculation without any crash.

Are there any changes I should follow up if I run this example with QE 6.3 or is this any installation error or a bug?


Thank you in advance.

Inoka

Author:  sponce [ Tue Aug 07, 2018 11:30 pm ]
Post subject:  Re: EPW5.3

Dear Inoka,

Can you go in q-e-6.3/test-suite/ and run the epw test (for example the epw_base).

If those are working, the q-e6.3 should be correctly installed.

If it is working but the lead example from the school is not working, then it is a bit weird and I will give it a try.

Best wishes,
Samuel

Author:  inoka [ Wed Aug 08, 2018 4:54 pm ]
Post subject:  Re: EPW5.3

Dear Dr. Samuel

I tried q-e-qe-6.3\test-suite\epw_metal
I got the same error in epw.out


Error in routine readwfc (20):
error opening wfc file


As same as in the previous case, this finished properly in my system with QE 6.2.2.


I also tried q-e-qe-6.3\test-suite\epw_base. But both my system and supercomputer gave the same error for epw.out which I suspect that something is wrong with epw.in. But I couldn't figure it out. I tried removing parallel_k and parallel_q, but it didn't help.

error:
task # 0
from epw_readin : error # 17
reading input_epw namelist


epw.in

--
&inputepw
prefix = 'diam'
amass(1) = 12.01078
outdir = './'

iverbosity = 0

elph = .true.
epbwrite = .true.
epbread = .false.

etf_mem = 1

epwwrite = .true.
epwread = .false.

nbndsub = 4
nbndskip = 0

wannierize = .true.
num_iter = 300
iprint = 2
dis_win_max = 12
dis_froz_max= 7
proj(1) = 'f=0,0,0:l=-3'

elecselfen = .true.
phonselfen = .false.
a2f = .false.

parallel_k = .true.
parallel_q = .false.

fsthick = 15 ! eV
eptemp = 300 ! K (same as PRB 76, 165108)
degaussw = 1.0 ! eV

dvscf_dir = './save/'
filukk = './diam.ukk'

nkf1 = 6
nkf2 = 6
nkf3 = 6

nqf1 = 6
nqf2 = 6
nqf3 = 6

nk1 = 3
nk2 = 3
nk3 = 3

nq1 = 3
nq2 = 3
nq3 = 3
/
4 cartesian
0.000000000000 0.000000000000 0.000000000000 0.0740741
-0.333333333333 0.333333333333 -0.333333333333 0.5925926
0.000000000000 0.666666666667 0.000000000000 0.4444444
0.666666666667 0.000000000000 0.666666666667 0.8888889



Thank you
Inoka

Author:  sponce [ Thu Aug 09, 2018 8:49 am ]
Post subject:  Re: EPW5.3

Hello,

How did you download your qe-6.3 ?
You can get it from https://github.com/QEF/q-e/releases/tag/qe-6.3

Then in qe-6.3/test-suite/epw_metal
you should get for epw.in

Code:
--
&inputepw
  prefix      = 'pb'
  amass(1)    = 207.2
  outdir      = './'

  elph        = .true.
  kmaps       = .false.
  epbwrite    = .true.
  epbread     = .false.

  epwwrite    = .true.
  epwread     = .false.

  nbndsub     =  4
  nbndskip    =  5

  wannierize  = .true.
  num_iter    = 300
  dis_win_max = 21
  dis_win_min = -3
  dis_froz_min= -3
  dis_froz_max= 13.5
  proj(1)     = 'Pb:sp3'

  wdata(1) = 'bands_plot = .true.'
  wdata(2) = 'begin kpoint_path'
  wdata(3) = 'G 0.00 0.00 0.00 X 0.00 0.50 0.50'
  wdata(4) = 'X 0.00 0.50 0.50 W 0.25 0.50 0.75'
  wdata(5) = 'W 0.25 0.50 0.75 L 0.50 0.50 0.50'
  wdata(6) = 'L 0.50 0.50 0.50 K 0.375 0.375 0.75'
  wdata(7) = 'K 0.375 0.375 0.75 G 0.00 0.00 0.00'
  wdata(8) = 'G 0.00 0.00 0.00 L 0.50 0.50 0.50'
  wdata(9) = 'end kpoint_path'
  wdata(10) = 'bands_plot_format = gnuplot'

  iverbosity  = 0

  elecselfen  = .true.
  phonselfen  = .true.
  a2f         = .true.


  fsthick     = 6 ! eV
  eptemp      = 300 ! K
  degaussw    = 0.1  ! eV
  degaussq    = 0.05 ! meV

  dvscf_dir   = './save'
  filukk      = './SiC.ukk'

  nkf1        = 6
  nkf2        = 6
  nkf3        = 6

  nqf1        = 6
  nqf2        = 6
  nqf3        = 6

  nk1         = 3
  nk2         = 3
  nk3         = 3

  nq1         = 3
  nq2         = 3
  nq3         = 3
/
      4 cartesian
  0.000000000000   0.000000000000   0.000000000000
-0.333333333333   0.333333333333  -0.333333333333
  0.000000000000   0.666666666667   0.000000000000
  0.666666666667   0.000000000000   0.666666666667


As you can see there are no weights form q-points lists and no parallel_k/q.

Where did you get your input from ?

Best wishes,
Samuel

Author:  inoka [ Thu Aug 09, 2018 11:34 am ]
Post subject:  Re: EPW5.3

Dear Dr. Samuel

I downloaded it from https://gitlab.com/QEF/q-e/tags/qe-6.3.
And I have tried that example removing q and k parameters since I remembered they should be not there. The previous post is for that trial.


As your instructions I downloaded it from github and tried again with QE6.3 in our supercomuters. The error remains the same. BTW I wasn't sure about scf_epw.in. please tell me for what is that input?

I did only scf.in, ph.in, (pp.py), nscf_epw.in and epw.in only.

Thank you
Inoka

Author:  sponce [ Fri Aug 10, 2018 9:16 am ]
Post subject:  Re: EPW5.3

Dear Inoka,

You should do scf.in, ph.in, (pp.py), scf_epw.in, nscf_epw.in and epw.in

However, I dont think it will help you much.

When you say the error remains, you are talking about that error :
Code:
error:
task # 0
from epw_readin : error # 17
reading input_epw namelist


or the wf reading problem ?

The first one should not be. The second one could be a compilation problem.

Best wishes,
Samuel

Author:  inoka [ Mon Aug 13, 2018 5:22 pm ]
Post subject:  Re: EPW5.3

Dear Dr. Sponce

Yes, I mean the "error opening wfc file"

Is this then definitely a compilation error of epw?
Can you please send me the instructions to compile epw in QE6.3? I wanted to install it in my system and try before I ask Supercomputer to re do it.
I downloaded it from github link you have provided. But I could not find the way to compile it.

Thank you

Inoka

Author:  sponce [ Tue Aug 14, 2018 9:34 pm ]
Post subject:  Re: EPW5.3

Hello,

Yes I was lazy and did not update the Download and install part of the EPW website.

I've just done it http://epw.org.uk/Main/DownloadAndInstall

Also note the tests at the end. I recommend to always perform them.

Best wishes,
Samuel

PS: Its version 5 not 5.3 of EPW.

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/