It is currently Sun Jan 20, 2019 11:52 am

Tell a friend!


Post new topic Reply to topic  [ 5 posts ] 
Complie error for EPW-4 
Author Message

Joined: Sat Apr 02, 2016 5:55 pm
Posts: 16
Post Complie error for EPW-4
Dear all,

Hello.

I have questions about compilation for EPW-4.

As README file guides me, I installed latest version of QE (QE 5.3.0) and copied folder from sponce's branch.

But, I got error messages as below.

mpif90 -O2 -assume byterecl -g -traceback -par-report0 -vec-report0 -nomodule -fpp -D__INTEL -D__FFTW3 -D__MPI -D__PARA -D__SCALAPACK -I../../include -I../../iotk/src -I../../Modules -I../../LAXlib -I../../iotk/src -I../../FFTXlib -I../../PW/src -I../../LR_Modules -I../../PHonon/PH -I../../PP/src -I. -c elph2.f90
elph2.f90(12): error #7002: Error in opening the compiled module file. Check INCLUDE paths. [KINDS]
USE kinds, ONLY : DP
------^
elph2.f90(16): error #6683: A kind type parameter must be a compile-time constant. [DP]
COMPLEX(KIND=DP), ALLOCATABLE :: &
---------------^
elph2.f90(37): error #6683: A kind type parameter must be a compile-time constant. [DP]
REAL(KIND=DP), ALLOCATABLE ::&
------------^
elph2.f90(69): error #6683: A kind type parameter must be a compile-time constant. [DP]
REAL(KIND=DP) :: &!
------------^
elph2.f90(12): error #6580: Name in only-list does not exist. [DP]
USE kinds, ONLY : DP
---------------------^
compilation aborted for elph2.f90 (code 1)
make[1]: *** [elph2.o] Error 1
make[1]: Leaving directory `/home/users/hanwooh/espresso/EPW/src'
make: *** [epw] Error 2

I didn't modify the original code.

Could anyone help me with this?

Thank you.


Tue Apr 05, 2016 5:57 am
Profile E-mail

Joined: Sat Apr 02, 2016 5:55 pm
Posts: 16
Post Re: Complie error for EPW-4
Sorry, it was my mistakes.

I fixed this problem.

Thank you.


Tue Apr 05, 2016 2:38 pm
Profile E-mail
Site Admin
User avatar

Joined: Wed Jan 13, 2016 7:25 pm
Posts: 534
University: Oxford
Post Re: Complie error for EPW-4
Glad to hear it !

Best,

Samuel

_________________
Dr. Samuel Poncé
Department of Materials
University of Oxford
Parks Road
Oxford OX1 3PH, UK


Tue Apr 05, 2016 3:00 pm
Profile E-mail

Joined: Fri Apr 08, 2016 11:02 pm
Posts: 81
Post Re: Complie error for EPW-4
Hello,

I downloaded espresso-5.3.0 and EPW-4. I followed the instructions for compiling but got the same error as hanwooh. Does anyone know how to avoid this error?

Thank you,

Vahid

Vahid Askarpour
Department of Physics and Atmospheric Science
Dalhousie University
Halifax, NS Canada


Fri Apr 08, 2016 11:08 pm
Profile E-mail

Joined: Fri Apr 08, 2016 11:02 pm
Posts: 81
Post Re: Complie error for EPW-4
To add to me earlier post, I tried espresso-4.0.3 with EPW-3.0.0 and the compilation works fine. I really like to install EPW-4 and noted that in the EPW-4 examples, the espresso used with EPW-4 is espresso-5.2.0. I tried espresso-5.2.0 with EPW-4 but I still get the same error as before i.e.,

(cd src ; make )
make[1]: Entering directory `/global/home/vahid/bin/PWSCF+EPW/espresso-5.2.0/EPW/src'
mpif90 -O2 -assume byterecl -g -traceback -nomodule -fpp -D__INTEL -D__FFTW -D__MPI -D__PARA -D__SCALAPACK -I../../include -I../../iotk/src -I../../Modules -I../../LAXlib -I../../iotk/src -I../../FFTXlib -I../../PW/src -I../../LR_Modules -I../../PHonon/PH -I../../PP/src -I. -c io_epw.f90
mpif90 -O2 -assume byterecl -g -traceback -nomodule -fpp -D__INTEL -D__FFTW -D__MPI -D__PARA -D__SCALAPACK -I../../include -I../../iotk/src -I../../Modules -I../../LAXlib -I../../iotk/src -I../../FFTXlib -I../../PW/src -I../../LR_Modules -I../../PHonon/PH -I../../PP/src -I. -c elph2.f90
elph2.f90(12): error #7002: Error in opening the compiled module file. Check INCLUDE paths. [KINDS]
USE kinds, ONLY : DP
------^
elph2.f90(16): error #6683: A kind type parameter must be a compile-time constant. [DP]
COMPLEX(KIND=DP), ALLOCATABLE :: &
---------------^
elph2.f90(37): error #6683: A kind type parameter must be a compile-time constant. [DP]
REAL(KIND=DP), ALLOCATABLE ::&
------------^
elph2.f90(69): error #6683: A kind type parameter must be a compile-time constant. [DP]
REAL(KIND=DP) :: &!
------------^
elph2.f90(12): error #6580: Name in only-list does not exist. [DP]
USE kinds, ONLY : DP
---------------------^
compilation aborted for elph2.f90 (code 1)
make[1]: *** [elph2.o] Error 1
make[1]: Leaving directory `/global/home/vahid/bin/PWSCF+EPW/espresso-5.2.0/EPW/src'
make: *** [epw] Error 2

Any suggestion would be really appreciated.

Vahid


Sat Apr 09, 2016 6:55 pm
Profile E-mail
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © phpBB Group.
Designed by Vjacheslav Trushkin

(All content on this board is governed by and is the sole responsibility of the board administrator.)


Gratis forum Free forum hosting| gratis phpbb3 forum | phpbb3 styles