It is currently Tue Oct 22, 2019 4:41 pm

Tell a friend!

Post new topic Reply to topic  [ 4 posts ] 
Problems with examples from /test-suite 
Author Message

Joined: Thu Mar 21, 2019 2:27 pm
Posts: 8
University: UFBA
Post Problems with examples from /test-suite
Dear EPW team and users

To begin with, apologies if this is a silly question.

I'm triying to begin working with the EPW package, and a few days ago I installed it, (version 5.1), with the new QE 6.4 (downloaded from: ... e_pack.tgz). The installation process seemed to be successful, as there were no error messages, and the epw.x appeared in the bin folder.

However, when I tried to start learning the code, working on the diamond example from /examples, following the instructions from the tutorial ( Everything works well, until the step of using, when an error message shows, about the file "diam.fc", which is missing.

I also tried the Pb example from this tutorial ( ... al/0/0.pdf), and tha same happens, asks for a lead.fc file, which was not created during the scf and phonons calculations. If I keep on with the examples, ignoring this error, and proceed to the scf/nscf calculations, when I run epw.x with the, the program crashes with a warning STOP 1, and the epw.out contains the message:

Error in routine epw_readin (5010):
reading input_epw namelist

This happened for both examples. I also tried working with the input files from epw-metal and epw-base, from the test-suite directory, but the same happens.

Finally, I tried to run all the epw tests with "make run-tests-epw-parallel", to see if everything was ok, but at the end of the run I got the message:
All done. ERROR: only 0 out of 26 tests passed (47 skipped).

As I could not find any similar issue in previous posts, any help will be very appreciated.

Thanks for the assistance, and sorry for the long post
Fabio Costa

Thu Mar 21, 2019 3:21 pm
Profile E-mail

Joined: Thu Mar 21, 2019 2:27 pm
Posts: 8
University: UFBA
Post Re: Problems with examples from /test-suite
After I Reinstalled everything, things started to work normally. Now the tests from /test_suite were all performed successfully. It was probably something wrong that I did during the first try.

Sorry about the false warning.

Fri Mar 22, 2019 2:31 pm
Profile E-mail
Site Admin
User avatar

Joined: Wed Jan 13, 2016 7:25 pm
Posts: 573
University: Oxford
Post Re: Problems with examples from /test-suite
Hello Fabio Costa,

Glad to hear that it now works for you !


Dr. Samuel Poncé
Department of Materials
University of Oxford
Parks Road
Oxford OX1 3PH, UK

Mon Mar 25, 2019 9:59 am
Profile E-mail

Joined: Fri Apr 26, 2019 11:39 am
Posts: 18
University: Antwerp University
Post Re: Problems with examples from /test-suite
Dear EPW users,

I happened to encounter a similar problem to the one discussed in this post.
I didn't quite get what exactly was the solution. Could someone give an advice on what might cause this kind of problem and how to remedy it?
I use quantum espresso installed on a cluster and for me reinstalling is really a last resort.

Thank you!
Best regards, Mikhail

Thu May 02, 2019 1:18 pm
Profile E-mail
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © phpBB Group.
Designed by Vjacheslav Trushkin

(All content on this board is governed by and is the sole responsibility of the board administrator.)

Gratis forum Free forum hosting| gratis phpbb3 forum | phpbb3 styles